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For this project I was to find 3 functions in the same program and for each function, demonstrate one instance where it works well, and one instance where it works poorly.  I will demonstrate this using the modeling of user tasks, doing KLM and GOMS models for 3 different people by observing their actions when I ask them to perform each instance of the 3 functions.
The program I chose was Microsoft Word (Office 2003 edition), and the reason I chose it is because most people that use it, don’t come close to using it to its full potential.  Word is full of useful functions that the majority of regular users don’t even know exist.  Most people use word only to type letters, and save or print them, but if people knew what else they could do with it, they might be surprised to find how much easier it can make things.  This makes for an interesting tie-in for the purposes of this project, you could make the argument that Word itself doesn’t work very well because it is so complex that people don’t know how to fully utilize it.  However, I am going to say that like anything else, Word needs to be learned to be used properly, and once someone has learned to use it, Word will become much more user-friendly.  
So, what I did was took 3 people that have varying experience using Word, and asked them to do something that they have never done before with it.  First I let them figure it out themselves by looking at the different menus, giving slight hints if they get way off track.  Then I show them shortcuts that they’ve probably seen many times, but didn’t know how to use, that make the task much easier.  I take KLM notes for everybody, detailing each step that they take. 

The three functions I am using for this project is inserting a table with 2 rows and 2 columns into the Word document, printing an envelope from the “Envelopes and Labels” window, and drawing a square and a circle on the document using the drawing toolbar.  None of the 3 people I am using for this project had ever done any of these before, so only their familiarity with computers in general will help them in doing the task.  For each test, I have the user sit down in front of a computer that already has Word open and ready to use, and I will simply ask them to do something.
Optimal Keystroke Level Models for the functions

Here I will detail what I would call optimal KLM for every instance that will be tested by the users.  This will give us something to compare all the users KLMs to.  These models would be performed by super users who know exactly what to do to achieve their goals with a minimal amount of mental time spent thinking.
First though, a legend of all the KLM notations I will be using in my reports:

	Action
	Description
	Time (in seconds)

	M
	Mental Thinking Time
	1.2

	P
	Point to something with mouse pointer
	1.1

	H
	Home hands on keyboard or mouse
	0.4

	K(x)
	Keystrokes
	x * 0.28

	B
	Click button down
	0.1

	BB
	Click and release button
	0.2

	W(x)
	Wait for system to respond
	x 


Function 1: Tables
Inserting a table with 2 columns and 2 rows, first through the menus
	Action
	Additional Description
	Time (in seconds)

	P
	Point at “Table” tab
	1.1

	BB
	
	0.2

	P
	Point at “Insert” option
	1.1

	BB
	
	0.2

	P
	Point at “Table” option
	0.5

	BB
	
	0.2

	P
	Point at the down arrow for columns
	1.1

	BB*3
	Change it to 2
	0.6

	P
	Point at “Ok”
	1.1

	BB
	DONE
	0.2


Total Time:    6.3 seconds

Give or take a mental unit or two, we’re looking at anywhere from 6.3 to 8.7 seconds

Now with the menu that lets you insert tables quickly. The one that looks like this [image: image1.png]



	Action
	Additional Description
	Time (in seconds)

	P
	Point at “Table” icon
	1.1

	BB
	
	0.2

	P
	Point at 2 x 2 icon
	1.1

	BB
	DONE
	0.2


Total Time:    2.6 seconds

Give or take a mental unit or two, we’re looking anywhere from 2.6 to 5 seconds

Function 2: Printing an Envelope
Printing on an envelope is another useful feature in Word that most people don’t know exists.  Where I work, I have to print the address on every envelope I send, it makes it look more professional than a handwritten envelope.  While home users aren’t likely to need to use it all the time, when sending a resume, or sending something to a lawyer or financial representative it might look nicer to take the extra time to print the address on the envelope.  This function is also important to anyone who works out of their home.

	Action
	Additional Description
	Time (in seconds)

	P
	Point at “Tools” tab
	1.1

	BB
	
	0.2

	P
	Point at “Letters and Mailings”
	1.1

	BB
	
	0.2

	P
	Point at “Envelopes and Labels”
	0.5

	BB
	
	0.2

	P
	Point at “Print”
	1.1

	BB
	DONE
	0.2


Total Time:    4.6 seconds
The range here is anywhere from 4.6 to 6 seconds

Since there are no easy icons on the toolbar that allows a user to skip right to the Envelopes and Labels window (by default that is, you can customize the toolbar to add on) I will just have them do the same thing over again.  This simulates someone who has used the function before, and knows where to go to find it.

The optimal KLM for both instances are the same, since they will be doing the same thing, however the users will be much quicker the second time around.

Fnction 3: Drawing Objects
For this test, I will ask the users to draw a square and a circle on the document, first by going through the menus.

	Action
	Additional Description
	Time (in seconds)

	P
	Point at “Insert” tab
	1.1

	BB
	
	0.2

	P
	Point at “Picture”
	1.1

	BB
	
	0.2

	P
	Point at “New Drawing”
	1.1

	BB
	
	0.2

	P
	Point at square icon
	1.1

	BB
	
	0.2

	P
	Point at the document
	1.1

	B
	Hold down button
	0.1

	P
	Point at another point in the document
	1.1

	B
	Release buton
	0.1

	P
	Point at circle icon
	1.1

	BB
	
	0.2

	P
	Point at the document
	1.1

	B
	Hold down button
	0.1

	P
	Point at another point in the document
	1.1

	B
	Release buton DONE
	0.1


Total Time:  11.3 seconds

So our range is 11.3 to 13.9 seconds

Next I will show them the Drawing Icon on the standard menu bar that brings up the drawing toolbar, it looks like this: [image: image2.png]



	Action
	Additional Description
	Time (in seconds)

	P
	Point at “Drawing” icon
	1.1

	BB
	
	0.2

	P
	Point at square icon
	1.1

	BB
	
	0.2

	P
	Point at the document
	1.1

	B
	Hold down button
	0.1

	P
	Point at another point in the document
	1.1

	B
	Release buton
	0.1

	P
	Point at circle icon
	1.1

	BB
	
	0.2

	P
	Point at the document
	1.1

	B
	Hold down button
	0.1

	P
	Point at another point in the document
	1.1

	B
	Release buton DONE
	0.1


Total Time:    8.7 seconds

So our range is 8.7 to 10.3 seconds.
Subject 1: Amber Battice
Amber is my girlfriend, she is my age and is also a college student.  She knows her way around a computer, and has used Word many times to type letters or school projects.  She is also temporarily handicapped, as a brain surgery last year has left her somewhat weak on her left side, making her left hand very hard to use on a keyboard.

Function 1: Tables
For the first test, I asked Amber to insert a table with 2 columns and 2 rows, it was up to her to figure it out.

	Action
	Additional Description
	Time (in seconds)

	P
	She points at the menu bar, without clicking
	1.1

	M
	
	1.2

	P
	She points at the “Table” tab
	0.5

	BB
	
	0.2

	P
	Points at “Insert” 
	0.5

	W(0.5)
	Waits for the submenu to appear
	0.5

	P
	Points at “Table”
	0.5

	BB
	
	0.2

	M
	
	1.2

	P
	Points at the down arrow for number of columns
	1.1

	BB*3
	Changes it to 2
	0.6

	P
	Points at the OK button
	1.1

	BB
	Done
	0.2


Total Time:    8.9 seconds
Now 8.9 seconds is pretty good for someone who’s never done it before, this is most likely due to her overall familiarity with using the computer, and her understanding of how things are likely to be grouped in the menu bar.  
For the next run, I showed her the icon in the standard tool bar that lets you quickly create a table.  

	Action
	Additional Description
	Time (in seconds)

	P
	Points at the icon
	1.1

	BB
	
	0.2

	P
	Points at the 2 x 2 icon
	1.1

	BB
	Done
	0.2


Total Time:    2.6 seconds

Amber actually achieves optimal time here, so using the helpful icon is much faster and easier than wading through all the convoluted menus in Word.
Function 2: Printing an Envelope

So for the test, I asked Amber to print a blank envelope, this tests how long it would take her to find the envelope icon, and print, not how long it would take to actually type an address.

	Action
	Additional Description
	Time (in seconds)

	M * 2
	She wasn’t sure what to do at first
	2.4

	P
	She pointed at the “File” tab in the main menu bar
	1.1

	BB
	
	0.4

	M * 5
	She looked at the options in the “File” tab
	6

	P
	She points at the “Page Setup” option
	1.1

	BB
	
	0.2

	M * 3
	She thinking what to do.  NOTE: At this point I see that she’s going down the wrong track, so I told her to look in the tools menu instead.
	3.6

	P
	She points at the “Tools” tab in the main menu bar
	1.1

	BB
	
	0.2

	M * 2
	She’s looking at what to choose
	2.4

	P
	She points at the “Letters and Mailings” option
	1.1

	W(0.5)
	Waits for the submenu to appear
	0.5

	P
	She points at the “Envelopes and Labels” option
	0.5

	BB
	
	0.2

	P
	She points at “Print”
	1.1

	BB
	Done
	0.2


Total Time:  22.1 seconds
This is a long time just to choose something to do, and it can be attributed to the fact that she didn’t know that this function existed, but also that it’s not readily apparent where to go to print an envelope.  I will go into more detail about that later on. Also note that I had to help her out, or it would have taken much longer for her to find it. 
I asked her to try doing it again after having done it once
	Action
	Additional Description
	Time (in seconds)

	P
	She points at the “Tools” tab in the main menu bar
	1.1

	BB
	
	0.2

	M
	She’s looking at what to choose
	1.2

	P
	She points at the “Letters and Mailings” option
	1.1

	W(0.5)
	Waits for the submenu to appear
	0.5

	P
	She points at the “Envelopes and Labels” option
	0.5

	BB
	
	0.2

	P
	She points at “Print”
	1.1

	BB
	Done
	0.2


Total Time:    6.1 seconds

Obviously this is much faster, knowing how to do something takes a ton of time out of the task.  Even though she had just done it and it was fresh in her mind, if she hadn’t used the function for some time, she would still at least know where to look.

Function 3: Drawing Objects
The drawing toolbar can be very useful for including diagrams in a Word document, yet most people either don’t know about it, or just take an image of a diagram and paste it into the document.  For this test, I asked Amber to draw a square and a circle onto the document.

	Action
	Additional Description
	Time (in seconds)

	M * 2
	
	2.4

	P
	Points to the “Insert” tab on the main menu bar
	1.1

	BB
	
	0.2

	M * 3
	Looks at the options
	3.6

	P
	Points to the “Picture” option
	1.1

	W(0.5)
	Waits for the submenu to appear
	0.5

	P
	Points to the “AutoShapes” option
	1.1

	BB
	
	0.2

	M
	
	2.4

	P
	Points to the “X” icon on the AutoShapes bar that popped up
	1.1

	BB
	Closes AutoShapes bar
	0.2

	M
	
	1.2

	P
	Points at the Drawing toolbar which also popped up
	1.1

	M
	
	1.2

	P
	Points at the Square icon
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	B
	Holds down button
	0.1

	P
	Points to another point
	0.5

	B
	Lets up on the button, creates a square
	0.1

	P
	Points at the Circle icon
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	B
	Holds down button
	0.1

	P
	Points to another point
	0.5

	B
	Lets up on the button, creates a circle, DONE
	0.1


Total Time:  23.6 seconds
This is pretty good for someone who had not done it before, and since it required actually creating the drawings its going to take longer than other functions.

For the next run, I showed Amber the icon that is on the standard toolbar that brings up the drawing toolbar automatically.
	Action
	Additional Description
	Time (in seconds)

	P
	Points at the Drawing Icon
	1.1

	BB
	
	0.2

	P
	Points at the Square icon (on the Drawing toolbar)
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	B
	Holds down button
	0.1

	P
	Points to another point
	0.5

	B
	Lets up on the button, creates a square
	0.1

	P
	Points at the Circle icon
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	B
	Holds down button
	0.1

	P
	Points to another point
	0.5

	B
	Lets up on the button, creates a circle, DONE
	0.1


Total Time:   7.5 seconds
As you can see, this is a large improvement.  This is another example of icons on the standard toolbar that are seldom used because people don’t know what they do.

Subject 2: Debbie Battice
Debbie is Ambers mother, she is pretty good with using a computer.  She mainly uses the internet, but she has written letters in Word before, and understands the most basic aspects of it, but she has never done anything more with it.  
Function 1: Tables
As before, I asked her to insert a table with 2 rows and 2 columns, and it was up to her to figure it out.
	Action
	Additional Description
	Time (in seconds)

	M * 3
	She’s thinks about what to do
	3.6

	P
	She points at the menu bar
	1.1

	M * 2
	
	2.4

	P
	She points at the “Table” tab
	0.5

	BB
	
	0.2

	M * 3
	
	3.6

	P
	She points at the “Table Autoformat” option
	1.1

	BB
	NOTE: At this point I had to correct her before she went any further.  I stressed that she needed to insert a table, and she caught on.
	0.2

	P
	Points to Cancel
	1.1

	BB
	
	0.2

	P
	Points to “Table”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points to “Insert” option
	0.5

	BB
	
	0.2

	P
	Points to “Table” option
	0.5

	BB
	
	0.2

	H
	Moves hands to keyboard
	0.4

	K(3)
	Types “2”, hits the Tab key, and Types “2” again
	0.84

	H
	Moves hand to mouse
	0.4

	P
	Points to OK
	1.1

	BB
	Done
	0.2


Total Time:  20.84
So there was some confusion, but she did finally get it after I gave her some help.

Next I showed her how to use the quick table icon on the standard tool bar.

	Action
	Additional Description
	Time (in seconds)

	M
	
	1.2

	P
	Points to the Table icon
	1.1

	BB
	
	0.2

	P
	Points to the 2x2 icon
	1.1

	BB
	Done
	0.2


Total Time:    3.8 seconds

Obviously this is a huge improvement, and a very easy feature to use once you learn how it works, and how to use the shortcut.
Function 2: Printing an Envelope
Again here I asked Debbie to print a blank envelope using the Word feature.

	Action
	Additional Description
	Time (in seconds)

	M * 3
	Thinking about what to do
	3.6

	P
	Points at the “Edit” tab on the main menu bar
	1.1

	BB
	
	0.2

	M * 6
	She is very confused and asks where it is, I told her to check the Tools tab
	7.2

	P
	Points at the “Tools” tab
	1.1

	BB
	
	0.2

	M * 4
	She reads every option aloud
	4.8

	P
	Points at “Letters and Mailings”
	1.1

	BB
	
	0.2

	P
	Points at “Envelopes and Labels”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at “Print”
	1.1

	BB
	Done
	0.2


Total Time:  23.3 seconds
Like Amber, Debbie has quite a bit of trouble with this one.  After spending some time looking at the options in the menu bar, she asked me for help, obviously frustrated.  Then once I gave her a hint she had to read every single option available in the Tools menu before settling on the correct option.

For the next run, I asked her to take what she just learned and do it over again.

	Action
	Additional Description
	Time (in seconds)

	M
	
	1.2

	P
	Points at the “Tools” tab
	1.1

	BB
	
	0.2

	M * 3
	She tries to find the right option
	3.6

	P
	Points at “Letters and Mailings”
	1.1

	BB
	
	0.2

	P
	Points at “Envelopes and Labels”
	0.5

	BB
	
	0.2

	P
	Points at “Print”
	1.1

	BB
	Done
	0.2


Total Time:    9.4 seconds

This was much faster, as expected, however noticeably slower than when Amber did it, which is most likely attributable to Ambers’ better knowledge of Word and computers in general.

Function 3: Drawing Objects
Here I asked Debbie to draw a square and a circle on the Word document.
	Action
	Additional Description
	Time (in seconds)

	M * 2
	
	2.4

	P
	Points at the “Tools” tab
	1.1

	BB
	
	0.2

	M * 4
	She seems frustrated and tells me she doesn’t know what shes doing, so told her that what shes doing is inserting the drawings, and she got it.
	4.8

	P
	Points at the “Insert” tab
	1.1

	BB
	
	0.2

	M * 3
	She reads all the options
	3.6

	P
	Points at the “Diagram” option
	1.1

	BB
	At this point I had to tell her she was on the wrong track, and to check the “Picture” option
	0.2

	P
	Points at the “Insert” tab
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at the “Picture” tab
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at “AutoShapes” option
	1.1

	BB
	
	0.2

	M * 2
	I had to point out that the drawing toolbar popped up at the bottom
	2.4

	P
	Points at the square icon
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points on the screen
	1.1

	B
	
	0.1

	P
	Points at a different point on the screen
	1.1

	B
	
	0.1

	P
	Points at the circle icon
	1.1

	BB
	
	0.2

	P
	Points on the screen
	1.1

	B
	
	0.1

	P
	Points at a different point on the screen
	1.1

	BB
	Done
	0.2


Total Time:  32.1 seconds
She had a lot of trouble navigating the menu in this run, again showing her frustration when she didn’t know what to do.  Still, she was able to navigate it and get the task done eventually.

Next I have her try using the Drawing icon

	Action
	Additional Description
	Time (in seconds)

	M
	
	1.2

	P
	Points at the “Drawing” icon in the main menu bar
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at the square icon in the drawing toolbar
	1.1

	BB
	
	0.2

	P
	Points on the screen
	1.1

	B
	
	0.1

	P
	Points at a different point on the screen
	1.1

	B
	
	0.1

	P
	Points at the circle icon in the drawing toolbar
	1.1

	BB
	
	0.2

	P
	Points on the screen
	1.1

	B
	
	0.1

	P
	Points at a different point on the screen
	1.1

	BB
	Done
	0.2


Total Time:  11.2 seconds
Again, it goes much faster using the convenient icon on the standard toolbar.

Subject 3: Jim Nardecchia
For my last subject, I used my father (also named Jim), he’s 62 years old, recently retired, and his computer was given to him by the UAW.  His interaction with the computer mainly consists of checking his e-mail, browsing the web, and playing solitaire (and occasionally the Golf game I got him last Christmas).   Basically he is your typical basic computer user, perhaps even less than.  He never learned to type on a keyboard, and even his one fingered “pecking” is slower than most peoples.  He’s never typed a letter on the computer, when he needs something typed up he always asks me to do it, so he’s never even used Word directly, which should make for some interesting results.
Function 1: Tables
Here I ask him to create a table with 2 rows and 2 columns.

	Action
	Additional Description
	Time (in seconds)

	M * 3
	He asks me to tell him what he’s supposed to do again
	3.6

	P
	Points to the “File” tab
	1.1

	BB
	
	0.2

	M*6
	He reads the options, asks me for some help
	7.2

	P
	Points at “Page Setup”
	1.1

	BB
	Clicks “Print Preview” by accident, I tell him that’s not right, and that there is actually a special tab just for tables.  I get him out of the print preview (he has no idea what just happened) and start him over again.
	0.2

	M 
	
	1.2

	P
	Points at the “Table” tab
	1.1

	BB
	
	0.2

	M*7
	Reads the options, I tell him again that he needs to insert a table with 2 rows and 2 columns.
	8.4

	P
	Points at the “Insert” option
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at the “Table” option
	1.1

	BB
	
	0.2

	M * 2
	He looks at the Table window
	2.4

	P
	Points at the down arrow for columns (defaults to 5)
	1.1

	BB*3
	Changes it to 2
	0.6

	P
	Points to “Ok”
	1.1

	BB
	Done
	0.2


Total Time:  33.5 seconds
Just as I suspected, my Dad takes the longest of all 3, which will probably be the case for every test.  If I hadn’t gotten him out of the print preview, who knows how long he would have been stuck.  

I show him the easy to use icon and ask him to insert a table again

	Action
	Additional Description
	Time (in seconds)

	M * 2
	Tries to find the icon
	2.4

	P
	Points to the icon
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points to the 2x2 icon
	1.1

	BB
	Done
	0.2


Total Time:    6.2 seconds
It took him a bit to find the icon, but after that he used it just fine, which goes to show you that when Word makes it easy, even novices can use its functions.

Function 2: Printing an Envelope
I asked him to print a blank envelope.

	Action
	Additional Description
	Time (in seconds)

	M * 5
	Thinking about which tab it would be under
	6

	P
	Points to “Format” tab
	1.1

	BB
	
	0.2

	P
	Points to “Paragraph”
	1.1

	BB
	I tell him that he should try looking in the Tools tab
	0.2

	P
	Points to “Cancel”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points to “Tools”
	1.1

	BB
	
	0.2

	M * 2
	Hes looking at the options
	2.4

	P
	Points to “Letters and Mailings”
	1.1

	BB
	
	0.2

	P
	Points to “Mail Merge”
	0.5

	BB
	I tell him that he was close, and to go back to where he was
	0.2

	P
	Points to “Cancel”
	1.1

	BB
	
	0.2

	P
	Points to “Tools”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points to “Letters and Mailings”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points to “Envelopes and Labels”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points to “Print”
	1.1

	BB
	Done
	0.2


Total Time:  26.9 seconds
Again here he had some trouble, clicking on two things that were incorrect, but he did eventually work his way through the menus to find it.
Next I ask him to take what he just learned and try to print the envelope again.

	Action
	Additional Description
	Time (in seconds)

	M
	
	1.2

	P
	Points at “Tools”
	1.1

	BB
	
	0.2

	M * 5
	Reads the options agin
	6

	P
	Points at “Letters and Mailings”
	1.1

	W(0.5)
	Waits for submenu to appear
	0.5

	P
	Points at “Envelopes and Labels”
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at “Print”
	1.1

	BB
	Done
	0.2


Total Time:  13.9 seconds
He had to re-read the options in the Tools menu, but this was still much faster than before.

Function 3: Drawing Objects
I asked him to draw a square and circle on the document.

	Action
	Additional Description
	Time (in seconds)

	M
	
	1.2

	P
	Points at “Tools”
	1.1

	BB
	
	0.2

	M * 5
	I tell him what hes really doing is inserting a drawing into the document
	6

	P
	Points at “Insert”
	1.1

	BB
	
	0.2

	M * 5
	Thinks and moves the cursor over all the options, when he scrolls over the “Picture” option, he notices the “Drawing” option in the submenu
	6

	P
	Points to “Drawing”
	1.1

	BB
	I point out the Drawing toolbar that popped up
	0.2

	M * 3
	
	3.6

	P
	Points at the square
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	BB*2
	Double clicks, which creates a square of arbitrary length
	0.4

	M
	
	1.2

	P
	Points at the circle
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	BB*2
	Double clicks, which creates a circle of arbitrary length. DONE
	0.4


Total Time:  27.5 seconds

This was actually quicker than Debbie, not bad for a novice, he was also the only one to click on the “Drawing” option instead of AutoShapes, and he noticed it all by himself, which was unexpected (no offense to my dad).

Now I show him the drawing toolbar icon and ask him to do that again

	Action
	Additional Description
	Time (in seconds)

	M
	
	1.2

	P
	Points at the Icon next to the Drawing icon
	1.1

	BB
	I tell him that was the wrong one
	0.2

	M
	
	1.2

	P 
	Points at the Drawing Icon
	1.1

	BB
	
	0.2

	M
	
	1.2

	P
	Points at the square
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	BB*2
	Double clicks, which creates a square of arbitrary length
	0.4

	M
	
	1.2

	P
	Points at the circle
	1.1

	BB
	
	0.2

	P
	Points on the document
	1.1

	BB*2
	Double clicks, which creates a circle of arbitrary length. DONE
	0.4


Total Time:  13 seconds

This was much easier and went much faster than doing it through the menus.

Comparisons
Here I will compare some of the values to come up with some data to use in my conclusion.

First I will create an optimal GOMS model so that I can compare it to the optimal KLM above, this will give us an idea on how different these two models are.

Function 1: Tables
Create a 2 x 2 table, first by going through the menus

Goal: Create a 2 x 2 Table


Method: Open the Table Window



Operator: Point at Table and click


1.2



Operator: Point at Insert and click

1.2



Operator: Point at Table and click


0.7


Finished Method: Table Window Open


Operator: Point at Down arrow for column

1.0


Operator: Click 3 times, changes to 2


0.6


Operator: Point at Ok and click



1.2

Accomplished Goal: Table Inserted

Total Time:
5.9

And now by using the icon on the standard toolbar

Goal: Create a 2 x 2 Table


Method: Use the Icon



Operator: Point at Icon and click


1.2



Operator: Point at 2 x 2 Icon and click

1.2


Finished Method: Using Icon

Accomplished Goal: Table Inserted

Total Time:
2.4
Function 2: Printing an Envelope

Print a blank envelope, there is only one way to do this

Goal: Print an Envelope


Method: Open the Envelopes and Labels Window



Operator: Point at Tools and click


1.2



Operator: Point at Letters and Mailings 





and click





1.2



Operator: Point at Envelopes and Labels





and click





0.7


Finished Method: Envelopes and Labels Window open


Operator: Point at Print and click



1.2

Accomplished Goal: Enveloped Printed
Total Time:
4.3
Function 3: Drawing Objects
Drawing a square and a circle

Goal: Draw a Square and a Circle


Goal: Draw a Square



Method: Open the Drawing toolbar




Operator: Point at Insert and click
1.2




Operator: Point at Picture and click
1.2




Operator: Point at New Drawing






and click




1.2



Finished Method: Drawing toolbar open



Operator: Point at square icon and click
1.2



Operator: Point at document



1.0



Operator: Hold down mouse button


0.1



Operator: Point somewhere else


1.0



Operator: Release mouse button


0.1


Accomplished Goal: Square drawn


Goal: Draw a Circle



Operator: Point at circle icon and click
1.2



Operator: Point at document



1.0



Operator: Hold down mouse button


0.1



Operator: Point somewhere else


1.0



Operator: Release mouse button


0.1


Accomplished Goal: Circle drawn

Accomplished Goal: Square and Circle drawn Total Time:10.4
And now using the drawing toolbar icon on the standard menu bar

Goal: Draw a Square and a Circle


Goal: Draw a Square



Method: Open the Drawing toolbar




Operator: Point at the Icon and click
1.2



Finished Method: Drawing toolbar open



Operator: Point at square icon and click
1.2



Operator: Point at document



1.0



Operator: Hold down mouse button


0.1



Operator: Point somewhere else


1.0



Operator: Release mouse button


0.1


Accomplished Goal: Square drawn


Goal: Draw a Circle



Operator: Point at circle icon and click
1.2



Operator: Point at document



1.0



Operator: Hold down mouse button


0.1



Operator: Point somewhere else


1.0



Operator: Release mouse button


0.1


Accomplished Goal: Circle drawn

Accomplished Goal: Square and Circle drawn Total Time: 8.0
Now we can compare the total time for the optimal GOMS model and the optimal KLM, which you can see in the graph below:
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As you can see, the GOMS is slightly faster than the KLM in every test.  This is because KLM is based off of a set of times for every actions that are the same for every user, whereas I based the GOMS model off of my own timing, which is slightly quicker.
Looking at the KLM for each instance of a function for every person can get pretty long, so I will try to illustrate just how faster the user can work when they use the shortcuts using the graphs below.

Amber Battice

[image: image4.emf]Tables

8.9

2.6

Menu

Icon


Debbie Battice

[image: image5.emf]Envelopes

22.1

6.1

1st run

2nd run


Jim Nardecchia
[image: image6.emf]Drawing Objects

23.6

7.5

Menu

Icon


Looking at it in graphic form really illustrates just how much time is saved by using the shortcuts.
Conclusion

Word is obviously very useful, but the problem is that it is more useful than people know.  Considering how expensive it is to purchase at retail its almost not worth the money if you don’t do any more than typing and saving documents.  

Like any other piece of software, you can’t expect people to pick up Word and instantly know how to use all of its features, people need to be taught first.  However, given how easy it is to utilize the icons that are always right in front of a user, rather than trying to navigate the confusing menus, it’s easy to see where a function performs poorly and where it performs well.  One of the things I noticed was how easy it was for the people I tested to use the icons instead of the menus, the graphical icons were much easier to understand for them than having to read every option in the menus.  
This brings me to the problem with printing an envelope.  The tools menu has the “Letters and Mailings” submenu that contains the “Envelopes and Labels” option.  The “Envelopes and Labels” option has a little icon of an envelope before it, which stands out against the bland gray menu.  If Microsoft chose to move this icon to the original submenu, I believe it would catch the eye or people, and would make it easier to find this option.  Using some basic screenshot manipulation, I have illustrated my idea below.
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As I said earlier, by default there is no easy icon on the menu bar for the Envelopes and Labels window, which contributes to it being so hard to find.

I always tell people who are afraid of computers, “if my dad can use one, anyone can”, and I believe that is a good example of what I found here.  If my father, who had never used Word before, can utilize the icons to do things much quicker, than anyone can do the same.  It takes a little bit of practice to become comfortable, but what software doesn’t. It makes me wonder how long it will be until we see Word using a predominately icon based interface, I believe it would help the basic users. 
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