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Statement of Problem

In designing a human interface for software, a developer has only a few methods available for divining the appropriate manner in which the application and user interact. The designer could work from her own intuition and experience, creating an interface providing access to functionality that she would desire personally. Working in this manner is known to create haphazard interface quality. The developing software team could hire the assistance of an expert in human interface design, which would produce a workable arrangement of controls by various facets of interface analysis. Though advisable for any software development project, the use of cognitive experts and experienced human interface designers is costly and difficult to use in an iterative development model where requirements are changing on the fly. The designer could conduct formal usability studies to iteratively develop the complete human interface for the application using user input. While usability studies should always be done, in reality these often follow the phase when many design choices have been made by the development team.

To ease the budgetary stress of hiring full-time human interface specialists, and to gain some of the practical input you would otherwise receive from potential users pounding on your prototypes, methods have been developed to give quantitative grounding to interface design decisions. These models use discrete human interaction events as a foundation for quantitative comparative analysis of interface alternatives. In this study, we will test the application of these analysis models by using them to estimate the time required to perform three functions in a commercial application by building a list of the steps the user must follow to make the application perform each function.

A challenge of interface design relates to the changing interaction state of an application. Performing a particular function may not be appropriate from all application states, and even when the function is applicable there may be multiple ways in which to trigger the function that vary according to the state of the application and myriad other factors. User experience, operating system state, the state of other applications, the state of other open documents in the active application, and the settings of configurable software preferences will all alter both the manner and stages of interaction. For our purposes, we will control these factors tightly and test only two different system states: one which is well suited for the function being tested, and one that negatively alters performance of the function.

This Study’s Models

We analyze two engineering models; Keystroke Level Model (KLM) and Goals Operators Methods Selection (GOMS) model.

Keystroke Level Model uses established timings for atomic human interaction events. One creates a serial list of these events for each function being analyzed and then sums the event timings to estimate the total time required to perform the function. The state of the software drastically affects the analysis, as the steps performed to reach the desired initial state for a particular KLM model must also be counted.

GOMS modeling also uses atomic timing events, but it is used to analyze the execution of the software function in a top-down approach rather than by stepping through a single execution of a function as with KLM. GOMS lends itself to developing interaction routines that are re-used, in much the same way software can be structured with sub-routines. From a set of top-level goals, analysis proceeds to detail the steps required to accomplish each goal, until the steps described are so small that they are keystroke-level. Important to GOMS is the inclusion of conditional user processing. GOMS analysis is well suited for simulation testing because it provides the minimal structural elements of a programming language, namely serial, conditional, and looping structures. The ‘flavor’ of GOMS used for this paper is a relaxed NGOMSL.

This Study’s Tasks and Functions

We will be looking at three common functions in Microsoft Word 2003 as used by a individuals familiar with but not expert in use of the application. The three functions have been chosen for analysis for their known frailties in response to application state which lend themselves to good vs. poor interface design comparisons.

1. Select the second sentence of the last paragraph, and Format it as Style ‘Heading 4’.

2. Reposition the image from the end of the document to just before the Table on page one.

3. Delete all content from a 4 row by 3 column table placed inline between two paragraphs, leaving the table intact.

In subsections for each function, our assumptions for ‘good’ and ‘poor’ system state will be clearly defined. We will create KLM estimates for execution of these three functions in each system state, and we will create GOMS models for each function that include the handling of  two system states. We will perform statistical analysis of these estimates against measures of three test users performing these functions precisely as defined. Since the users are being treated as inexperienced, we will try to insert ample mental operators in the process descriptions. We will use the following timings for each keystroke event.

K - key press 



0.2 sec = 55 wpm

P - point with mouse 


1.1 sec

B - mouse button press 


0.1 sec

BB - press and release button 

0.2 sec

H - home hands to keyboard or mouse 
0.4 sec

M - mental act of thinking 


1.2 sec
The tests were administered using these specially drafted, simplified instructions.
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Rules for Word’s configuration

A note regarding Word’s many viewing options. Since Word is so incredibly configurable and since access to functionality is altered by this configurability, we wish to control the initial setup. We will run the ‘less good’ scenarios first, then give the user a chance to learn other mechanisms, optimize views, and use a quicker method for performing a task before running the ‘more good’ scenarios.

The initial application state will use Normal view, with only the Standard and Formatting toolbars enabled. The test document is two pages long, contains some styles and a formatted table, and is saved as Read-Only on the local desktop. It will be opened and ready to use for the purpose of this test, and it will be reset between each task. The scenarios that improve functionality will be configured by the experimenter during the test in full view of the test subjects.

Function One

Select the second sentence of the last paragraph, and Format it as Style ‘Heading 4’.

Works Poorly

With Word’s interface in it’s default state, this is a very tedious function to perform.

1. Initiate location of last paragraph. (M)

2. Home hands to mouse. (H)

3. Point to scroll bar. (P)

4. Press & Hold bar. (B)

5. Confirm the scroll bar is clicked. (M)

6. Drag scroll bar to make target paragraph visible. (P)

7. Confirm the proper paragraph is visible. (M)

8. Release bar. (B)

9. Locate second sentence of last paragraph. (M)

10. Point to one end of the sentence. (P)

11. Press & Hold button. (B)

12. Point (drag) to the end of the sentence. (P)

13. Confirm the selection is correct.(M)

14. Release button. (B)

15. Verify the sentence is fully selected as intended. (M)

16. Locate the Style item in the Format menu. (M)

17. Point to Format Menu. (P)

18. Click 'Format' in menu. (BB)

19. Locate 'Styles and Formatting' in Format menu. (M)

20. Point to 'Styles and Formatting'. (P)

21. Click 'Styles and Formatting'. (BB)

22. Locate the 'Show' item in the bottom of the Styles and Formatting task pane. (M)

23. Point to the 'Show' dropdown. (P)

24. Click the dropdown control. (BB)

25. Locate the 'All Styles' item in the dropdown menu. (M)

26. Move hands to the Cursor (arrow) keys. (H)

27. Move to the 'All Styles' item in the list. (K)

28. Press Enter or Return. (K)

29. Verify All styles are available. (M)

30. Home hands to mouse. (H)

31. Point to scroll bar. (P)

32. Press & Hold bar. (B)

33. Confirm the scroll bar is clicked. (M)

34. Drag scroll bar to make 'Heading 4' visible. (P)

35. Confirm 'Heading 4' is visible. (M)

36. Release bar. (B)

37. Point to 'Heading 4' in the Pick formatting to apply window. (P)

38. Click on 'Heading 4' in the list. (BB)

39. Confirm the style has applied as expected. (M)

KLM Time Estimate: 2K + 10P + 6B + 4BB + 3H + 14M = 30.8 seconds

	Actual Execution Times: Poorly

	User A
	14.0

	User B
	16.3

	User C
	17.0


Works Better

A better situation develops when the document already contains an instance of the style ‘Heading 4’, or when the user has previously changed the view of the styles pane to show all styles. In these situations, once the selection of the target text is made, the user need only click ‘Heading 4’ in the styles pane or in the Styles dropdown in the formatting toolbar, should either already be visible during the editing session. We will now assume the task pane is visible. While the task panes are intended to made editing faster, this scenario has illustrated that there is a considerable penalty paid to configure the interface whenever a style is used for the first time.

1. Initiate location of last paragraph. (M)

2. Home hands to mouse. (H)

3. Point to scroll bar. (P)

4. Press & Hold bar. (B)

5. Confirm the scroll bar is clicked. (M)

6. Drag scroll bar to make target paragraph visible. (P)

7. Confirm the proper paragraph is visible. (M)

8. Release bar. (B)

9. Locate second sentence of last paragraph. (M)

10. Point to one end of the sentence. (P)

11. Press & Hold button. (B)

12. Point (drag) to the end of the sentence. (P)

13. Confirm the selection is correct.(M)

14. Release button. (B)

15. Verify the sentence is fully selected as intended. (M)

16. Locate 'Heading 4' in the Styles and Formatting pane. (M)

17. Point to 'Heading 4' in the Pick formatting to apply window. (P)

18. Click on 'Heading 4' in the list. (BB)

19. Confirm the style has applied as expected. (M)

KLM Time Estimate: 5P + 4B + 1BB + 1H + 8M = 16.1 seconds

	Actual Execution Times: Better

	User A
	8.0

	User B
	10.1

	User C
	9.0


GOMS Model for Function One


1
Accomplish goal: Select the second sentence of the last paragraph, and Format it as style 'Heading 4'.


1
Accomplish goal: Scroll to last paragraph of the document.


1
Initiate location of last paragraph. (M)


2
Home hands to mouse. (H)


3
Point to scroll bar. (P)


4
Press & Hold bar. (B)


5
Confirm the scroll bar is clicked. (M)


6
Drag scroll bar to make target paragraph visible. (P)


7
Confirm the proper paragraph is visible. (M)


8
Release bar. (B)


9
Return with goal accomplished.


2
Accomplish goal: Select the second sentence of the last paragraph.


1
Locate second sentence of last paragraph. (M)


2
Point to one end of the sentence. (P)


3
Press & Hold button. (B)


4
Point (drag) to the end of the sentence. (P)


5
Confirm the selection is correct.(M)


6
Release button. (B)


7
Verify the sentence is fully selected as intended. (M)


8
Return with goal accomplished.


3
Accomplish goal: Format the selected sentence with style 'Heading 4'.


1
Select method: If the Styles and Formatting pane is visible and 'Heading 4' is visible,

Accomplish goal: Directly select the style 'Heading 4' in the Styles and Formatting pane.


1
Accomplish goal: Select style 'Heading 4' in the Styles and Formatting pane.


2
Return with goal accomplished.


2
Select method: If the Styles and Formatting pane has not been opened in this document session,

Accomplish goal: Select the style 'Heading 4' in the Styles and Formatting pane.


1
Accomplish goal: Open the Styles and Formatting pane.


1
Locate the Style item in the Format menu. (M)


2
Point to Format Menu. (P)


3
Click 'Format' in menu. (BB)


4
Locate 'Styles and Formatting' in Format menu. (M)


5
Point to 'Styles and Formatting'. (P)


6
Click 'Styles and Formatting'. (BB)


7
Return with goal accomplished.


2
Accomplish goal: Show all styles in the Styles and Formatting pane.


1
Locate the 'Show' item in the bottom of the Styles and Formatting task pane. (M)(M)


2
Point to the 'Show' dropdown. (P)


3
Click the dropdown control. (BB)


4
Locate the 'All Styles' item in the dropdown menu. (M)


5
Move hands to the Cursor (arrow) keys. (H)


6
Move to the 'All Styles' item in the list. (K)


7
Press Enter or Return. (K)


8
Verify All styles are available. (M)


9
Return with goal accomplished.


3
Accomplish goal: Select style 'Heading 4' in the Styles and Formatting pane.


1
Locate 'Heading 4' style in the 'Pick formatting to apply window'.


2
Home hands to mouse. (H)


3
Point to scroll bar. (P)


4
Press & Hold bar. (B)


5
Confirm the scroll bar is clicked. (M)


6
Drag scroll bar to make 'Heading 4' visible. (P)


7
Confirm 'Heading 4' is visible. (M)


8
Release bar. (B)


9
Return with goal accomplished.


4
Return with goal accomplished.


3
Confirm the style has applied as expected. (M)


4
Return with goal accomplished.


4
Return with goal completed.


2
Submethod: Accomplish goal of selecting style 'Heading 4' in the Styles and Formatting pane.


1
Locate 'Heading 4' in the Styles and Formatting pane. (M)


2
Point to 'Heading 4' in the Pick formatting to apply window. (P)


3
Click on 'Heading 4' in the list. (BB)


4
Return with goal accomplished.
Function Two

Reposition the image from the end of the document to just before the Table on page 1.

Works Poorly

This task is challenging because of the way Word handles the text wrap around images. The image to be placed is set to text wrap ‘tightly’ rather than ‘Inline’. Even when an image is not designated ‘Inline’, it can not be freely placed anywhere on the page. Furthermore, the top edge of the image is still used to control placement on a given page or within the cell of a table. Using dragging to perform this task leads to many unpredictable and illogical results, such as completely hiding entire sections of the document. If the user accidentally inserts the image into a table cell, further dragging will be constrained to the interior of that cell rather than around the entire document. The actual execution times are expected to deviate significantly from the estimations. Note that the application must be placed in ‘Print Layout’ mode to view images, a fact that applies equally to both of  our scenarios and so will be ignored in our comparative analysis.

1. Initiate location of image. (M)

2. Home hands to mouse. (H)

3. Point to scroll bar. (P)

4. Press & Hold button. (B)

5. Drag scroll bar to make the image visible. (P)

6. Confirm the image is visible. (M)

7. Release bar. (B)

8. Point to Image. (P)

9. Click on the image. (B)

10. Drag the image up to the insert location. (P)

11. Locate the correct insert position. (M)

12. Release button. (B)

13. Verify the image is now located in the correct position. (M)

KLM Time Estimate: 4P + 4B + 1H + 4M = 10 seconds PLUS 

· the time waiting for the application to scroll and complete insertion

· the likely need to re-position the image multiple times at a cost of 4.8 seconds for each move

	Actual Execution Times: Poorly

	User A
	30.0

	User B
	12.2

	User C
	11.8


Works Better

The better way involves using keystrokes (or the inefficient Edit menu) to Cut and then Paste the image to an insertion point, then using the arrow keys to nudge the image into precise position.

1. Initiate location of image. (M)

2. Home hands to keyboard. (H)

3. Press key combination to move to end of document: Ctrl-End. (K)

4. Confirm the image is visible. (M)

5. Home to mouse. (H)

6. Point to Image. (P)

7. Click on the image. (BB)

8. Press key combination to cut the Image from the document:
Ctrl-X. (K)

9. Press key combination to move to beginning of document:
Ctrl-Home. (K)

10. Home to mouse. (H)

11. Point to insertion point for Image. (P)

12. Confirm the correct insertion point. (M)

13. Click insertion point in document. (BB)

14. Home to keyboard. (H)

15. Press key combination to paste Image at the insertion point:
Ctrl-V. (K)

16. Verify the image is now located in the correct position. (M)

KLM Time Estimate: 4K + 2P + 2BB + 4H + 4M = 9.8 seconds with no need for repetition!

	Actual Execution Times: Better

	User A
	9.0

	User B
	8.9

	User C
	10.0


GOMS Model for Function Two

1
Accomplish goal: Reposition the image from the end of the document to before the Table on page 1.


1
Accomplish goal: Move to the end of the document.


1
Select method: If user knows keyboard shortcuts for document navigation, Accomplish goal: move to end of document.


1
Home hands to keyboard. (H)


2
Press key combination to move to end of document: Ctrl-End. (K)


3
Confirm the image is visible. (M)


4
Home to Mouse. (H)


2
Select method: If user is unfamiliar with keyboard shortcuts for document navigation, 

Accomplish goal: move to end of document.


1
Home hands to mouse. (H)


2
Point to scroll bar. (P)


3
Press & Hold button. (B)


4
Drag scroll bar to make the image visible. (P)


5
Confirm the image is visible. (M)


6
Release bar. (B)


3
Return with goal accomplished.


2
Accomplish goal: Move the image to its destination.


1
Locate the image. (M)


2
Point to the image. (P)


3
Select method: If user knows keyboard shortcuts for editing and navigation, 

Accomplish goal: Move image into the target position.


1
Accomplish goal: Cut the image from its position.


1
Click on the image. (BB)


2
Press key combination to cut the Image from the document: Ctrl-X. (K)


3
Return with goal accomplished.


2
Accomplish goal: Move the image into its target position.


1
Press key combination to move to beginning of document: Ctrl-Home. (K)


2
Home to mouse. (H)


3
Point to insertion point for Image. (P)


4
Confirm the correct insertion point. (M)


5
Click insertion point in document. (BB)


6
Home to keyboard. (H)


7
Press key combination to paste Image at the insertion point: Ctrl-V. (K)


8
Return with goal accomplished.


3
Return with goal accomplished.


4
Select method: If user does not know keyboard shortcuts for editing and navigation,

Accomplish goal: Move image into the target position.


1
Click on the image. (B)


2
Drag the image up to the insert location. (P)


3
Locate the correct insert position. (M)


4
Release button. (B)


5
Return with goal accomplished.


5
Verify the image is now located in the correct position. (M)


6
Return with goal accomplished.


3
Return with goal completed.
Function Three

Delete all content from a 4 row by 3 column table placed inline between two paragraphs, leaving the table intact.

Works Poorly

This task is tricky because it depends upon a close knowledge of how Word deals with tables. One can’t simply select the content of the whole table alone, because doing so inherently includes selection of the table structure. Further complicating things, to delete table content, one might logically search through the ‘Table’ menu item or use a contextual menu with the table selected. Unlike the contextual menu for Images, Table menus only provide commands affecting structural elements of the table. The command required to delete table content is ‘Edit:Clear’, which is hidden from view on Word’s default compact menu layout. Let’s test the impact of using the mouse to poke around for the correct command versus using the simple keystrokes to access the table content deletion function.

1. Initiate the content deletion activity. (M)

2. Home to the mouse. (H)

3. Point to the upper left cell in the target table. (P)

4. Click & Hold the mouse button. (B)

5. Drag to the lower right cell of the target table. (P)

6. Confirm the pointer is positioned correctly. (M)

7. Release the mouse button. (B)

8. Locate the Edit menu. (M)

9. Point to the 'Edit' menu. (P)

10. Click on the 'Edit' menu. (BB)

11. Confirm the 'Clear' menu item is not available. (M)

12. Point to the menu expansion icon at the bottom of the menu. (P)

13. Click on the menu expansion icon. (BB)

14. Locate the 'Clear' item. (M)

15. Point to the 'Clear' item. (P)

16. Observe the submenu appear, containing the 'Contents' item. (M)

17. Point to the 'Contents' item. (P)

18. Click the 'Contents' item. (BB)

19. Confirm the table's contents are cleared. (M)

KLM Time Estimate: 6P + 2B + 3BB + 1H + 7M = 16.2 seconds

	Actual Execution Times: Poorly

	User A
	11.0

	User B
	7.6

	User C
	9.6


Works Better

To use the ‘good’ method of table content deletion, we are going to access the cryptic ‘table move handle’ icon that is displayed when the mouse hovers over a table when Word is in Print Layout. Since we are dependent on this layout, we will include a view switch in the analysis to account for the uncontrolled initial state.

1. Initiate the content deletion activity. (M)

2. Home to the mouse. (H)

3. Point to the 'View' menu. (P)

4. Click on the 'View' menu. (BB)

5. Locate the 'Print Layout' menu item. (M)

6. Click on the 'Print Layout' menu item. (BB)

7. Locate the target table. (M)

8. Point to the upper left corner of the target table. (P)

9. Observe the special 'table move handle' displayed outside the upper left boundary of the table. (M)

10. Point to the 'table move handle'. (P)

11. Click on the 'table move handle'. (BB)

12. Press key to delete table content: Del. (K)

13. Confirm the table's contents are cleared. (M)

KLM Time Estimate: 1K + 3P + 3BB + 1H + 5M = 10.5 seconds

	Actual Execution Times: Better

	User A
	7.0

	User B
	7.2

	User C
	12.9


GOMS Model for Function Three

1
Accomplish goal: Delete all content from a table leaving the table intact.


1
Accomplish goal: Select all table content.


1
Select method: If user's hands are on the Keyboard:


1
Home to the mouse (H)


2
Select method: If keyboard shortcuts are known,

Accomplish goal: Switch view to Normal and select content using table handle.


1
Point to the 'View' menu. (P)


2
Click on the 'View' menu. (BB)


3
Locate the 'Print Layout' menu item. (M)


4
Click on the 'Print Layout' menu item. (BB)


5
Locate the target table. (M)


6
Point to the upper left corner of the target table. (P)


7
Observe the special 'table move handle' displayed outside the upper left boundary of the table. (M)


8
Point to the 'table move handle'. (P)


9
Click on the 'table move handle'. (BB)


3
Select method: If keyboard shortcuts are unknown,

Accomplish goal: Select content by dragging.


1
Locate the upper left table cell on the screen. (M)


2
Point to the upper left cell in the target table. (P)


3
Click & Hold the mouse button. (B)


4
Drag to the lower right cell of the target table. (P)


5
Confirm the pointer is positioned correctly. (M)


6
Release the mouse button. (B)


4
Verify the table content has been selected. (M)


5
Return with the goal accomplished.


2
Accomplish goal: Delete all selected content.


1
Select method: If keyboard shortcuts are unknown,

Accomplish goal: Use menu command Clear|Contents to remove content.


1
Locate the Edit menu. (M)


2
Point to the 'Edit' menu. (P)


3
Click on the 'Edit' menu. (BB)


4
Confirm the 'Clear' menu item is not available. (M)


5
Point to the menu expansion icon at the bottom of the menu. (P)


6
Click on the menu expansion icon. (BB)


7
Locate the 'Clear' item. (M)


8
Point to the 'Clear' item. (P)


9
Observe the submenu appear, containing the 'Contents' item. (M)


10
Point to the 'Contents' item. (P)


11
Click the 'Contents' item. (BB)


2
Select method: If keyboard shortcuts are known,

Accomplish goal: Use Normal view and Delete key to remove content.


1
Home to keyboard. (H)


2
Press key to delete table content: Del. (K)


3
Verify the table's contents are cleared. (M)


3
Verify the table's contents are cleared. (M)


4
Return with the goal accomplished.


3
Return with goal completed.
Statistical Analysis

	Summary of test results

	
	
	Poor case (sec.)
	Better case (sec.)

	Function One
	KLM, GOMS Estimate
	30.8
	16.1

	 
	User A
	14.0
	8.0

	 
	User B
	16.3
	10.1

	 
	User C
	17.0
	9.0

	 
	Mean
	15.8
	9.0

	 
	Median
	16.3
	9.0

	 
	Std Dev
	1.6
	1.1

	 
	∆ Estimate-Mean
	15.0
	7.1

	 
	% error of estimate from Mean
	95.3%
	78.2%

	 
	% error of estimate from Median
	89.0%
	78.9%

	

	
	
	Poor case (sec.)
	Better case (sec.)

	Function Two
	KLM, GOMS Estimate
	10.0
	9.8

	 
	User A
	30.0
	9.0

	 
	User B
	12.2
	8.9

	 
	User C
	11.8
	10.0

	 
	Mean
	18.0
	9.3

	 
	Median
	12.2
	9.0

	 
	Std Dev
	10.4
	0.6

	 
	∆ Estimate-Mean
	-8.0
	0.5

	 
	% error of estimate from Mean
	-44.4%
	5.4%

	 
	% error of estimate from Median
	-18.0%
	8.9%

	

	
	
	Poor case (sec.)
	Better case (sec.)

	Function Three
	KLM, GOMS Estimate
	16.2
	10.5

	 
	User A
	11.0
	7.0

	 
	User B
	7.6
	7.2

	 
	User C
	9.6
	12.9

	 
	Mean
	9.4
	9.0

	 
	Median
	9.6
	7.2

	 
	Std Dev
	1.7
	3.4

	 
	∆ Estimate-Mean
	6.8
	1.5

	 
	% error of estimate from Mean
	72.3%
	16.2%

	 
	% error of estimate from Median
	68.8%
	45.8%


Conclusion

In each of the three functional tests, GOMS structure has been built using the keystroke-level steps from the KLM analyses. Therefore, the GOMS models by this research protocol do not vary in execution time estimation from those of the KLM model. A more rigorous and explicit GOMS protocol might deliver a different estimate, particularly if additional cognitive processing were included, such as those mentioned in Hochstein(2002).

One of the striking things seen here is how much lower the variance among ‘Better’ case results is in comparison to the ‘Poor’ case scenarios. This is in large part to the variability in physical and mental acuity of the mousing-heavy ‘Poor’ cases, where costly user missteps were subjectively observed by the researcher during execution. The models also did a better job of estimating real user activity during tasks that did not introduce mousing. Function Two’s ‘Poor’ case in particular contained a  drag of an object from the end of a Word document to the beginning of the document. During the move User A did not massage the interface by wiggling to accelerate the drag as did the other users, and User A initially misplaced the object, requiring a flustered re-placement.

In researching the way to structure the GOMS protocol, it was found that there is great disagreement over exactly how much the cognitive abilities of the user should influence the model, and debate over how to model variations in cognitive ability. The GOMS method is certainly useful in any form, though most important is its ability to make comparative statements about two ways of performing a task that share a majority of goals. When our models had a considerable departure between ‘Poor’ and ‘Better’ scenarios, particularly in the use of the mouse versus the keyboard, the GOMS model really broke down. It appears that a developer would need to invest some time into developing his or her own flavor of GOMS with some experimentation with users of the actual application at hand. Difficulty is further introduced by having the developer, inexperienced with human factors research, make assumptions about the learning abilities of users.
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